Bug #53

Unable to upload audio files

Added by Umfuld Johnson about 8 years ago. Updated about 8 years ago.

Status:Closed Start date:05/28/2011
Priority:Urgent Due date:
Assignee:Max Goldberg % Done:

100%

Category:Back-end Spent time: 4.00 hours
Target version:YTMND 2.1

Description

MP3s finish loading but never finish processing. Waves load but then show no audio file uploaded. Have been able to upload very small (under 100KB) MP3s only. This is in both site creator and editor.

MP3.mp3 (263.3 kB) Umfuld Johnson, 05/28/2011 11:33 pm

WAV.wav (963.8 kB) Umfuld Johnson, 05/28/2011 11:33 pm

History

#1 Updated by Umfuld Johnson about 8 years ago

  • Assignee deleted (Umfuld Johnson)

#2 Updated by Max Goldberg about 8 years ago

  • Category set to Back-end
  • Status changed from Unverified to Feedback
  • Assignee set to Max Goldberg

Can you provide browser/version/operating system? Also please attach one of the files that failed to upload/process here so I can try and reproduce this.

#3 Updated by Umfuld Johnson about 8 years ago

Firefox 3.6.17 / XP - another user reported same issue using Chrome and FF 4.0.1. I don't see the New File button under files here to upload a sample. Either I'm missing it or it's not enabled.

#4 Updated by Max Goldberg about 8 years ago

Click on Update and then you will have the option of attaching one or more files under the text area.

#5 Updated by Umfuld Johnson about 8 years ago

MP3- sendspace.com/file/bqf7jf
WAV- sendspace.com/file/zlsfiz

#6 Updated by Umfuld Johnson about 8 years ago

#7 Updated by Umfuld Johnson about 8 years ago

#8 Updated by Trent Chastain about 8 years ago

I am experiencing this as well, have tested with the following:
Windows 7-64, IE 8.0.7600.16385, Firefox 4.0.1, unknown Chrome version, and Unknown IE9 version, multiple computers as well (was certain it was something wrong on my end.)

When uploading an MP3, the Ajax json post is returning the following, which also triggers a java script error on the eval() in site_creator.js at line 1347. Multiple bitrates and encoders tried, all with the same results.

GOT AN ERROR PROCESSING SOUND FILE: >>===================================== file_name: /tmp/phpzsmIBF.mp3 file_type: MP3_ADTS instructions:

array
'decompress' => boolean true
'convert' => boolean false
'compress' => boolean true
'swf' => boolean false

new_file:

array
'new_file' => string '/var/php/uploads/MP3_ADTS_TO_WAV_58517feabec200b5eea522a7175ddbc7.wav' (length=69)
'output' => string '[audio.c:561] error: failed to open audio device
[mpg123.c:757] error: Failed to initialize output, goodbye.
' (length=109)

=====================================<<

On WAV files the Ajax post is simply returning 'false', I have no other information on that side of the issue unfortunately, but hope this info helps.

Thanks.

#9 Updated by Max Goldberg about 8 years ago

Thanks, this is helpful.

The MP3 ADTS encodes are converted server side but it looks like that's broken. I won't have access to fix it until tomorrow.

#10 Updated by Max Goldberg about 8 years ago

Hey guys, thanks for all your help in reporting this. I've fixed this on the production servers.

It isn't entirely clear how it happened, but the path to one of the required sound processing libraries got changed, so it wasn't able to retrieve information about sound files.

I've already tested and confirmed with the two files attached here, but if you have any other files that didn't work, please try and upload them so I can confirm I've fixed the problem.

#11 Updated by Max Goldberg about 8 years ago

  • Priority changed from High to Urgent
  • % Done changed from 0 to 100

Problem addressed in SVN revision #2003. Had to backport revision #1917 from YTMNDev to production, which should result in more JPEG file types being accepted, which I think is okay, but hasn't been tested thoroughly.

Previously, if the finfo or image magick libraries responded with:

  • 'Corrupt JPEG'
  • 'Invalid SOS parameters for sequential JPEG'
  • 'Premature end of JPEG file'

the files weren't allowed to be added to the asset system. Upon further checking a history of these errors 100% of the files I checked displayed just fine in browsers, so I decided to allow them into the system by ignoring those specific errors.

#12 Updated by Max Goldberg about 8 years ago

  • Status changed from Feedback to Closed

Got confirmation from someone on Meebo that their uploads were now being accepted, so I'm marking this as fixed.

Also available in: Atom PDF