Bug #30

Some zooming text unicode characters are empty boxes in preview thumbnails

Added by Biological Component about 8 years ago. Updated about 8 years ago.

Status:Verfied Start date:04/06/2011
Priority:Low Due date:
Assignee:Max Goldberg % Done:

10%

Category:Back-end Spent time: 8.00 hours
Target version:YTMND Future Estimated time:40.00 hours

Description

examples of site thumbnails with empty boxes (missing characters):
http://ytmnd.com/sites/518787/profile
http://ytmnd.com/sites/495012/profile
http://ytmnd.com/sites/523123/profile

examples of extended unicode that does show up in site thumbnails:
http://ytmnd.com/sites/467597/profile
http://ytmnd.com/sites/458831/profile

All unicode glyphs (that I've seen so far) are displayed on the YTMNDs themselves.

History

#1 Updated by Biological Component about 8 years ago

EDIT:

I just found a couple sites with empty characters in thumbnails that have an additional glitch where the site itself won't display anything but the background color...

http://graveyard.ytmnd.com/
http://secretchristiansymbol.ytmnd.com/

#2 Updated by Max Goldberg about 8 years ago

  • Status changed from New to Verfied
  • % Done changed from 0 to 10
  • Estimated time set to 40.00

I spent a good deal of time looking into this. First I tried a new version of the tahoma.ttf (which is 700k as opposed to the current file we're using at 300k). I made sure I was sending everything to GD as UTF-8, and I even tried decimal-escaping the text. I've been using the five sites above as a test and it looks like the issue is with freetype,

These don't work:

string(8) "〠"
string(7) "☪"
string(7) "☼"

These do work:

string(6) "İ"
string(7) "ڱ"

It looks like the extended unicode set just doesn't work on GD's imageTTFText. I wonder if i could use something else to generate this stuff.

I'm putting this on hold for now until YTMND 2.1 isn't so pressing.

Thanks, this is something I never would have paid attention to unless someone had brought it up first.

#3 Updated by Max Goldberg about 8 years ago

  • Target version changed from YTMND 2.1 to YTMND Future

Also available in: Atom PDF