Bug #28

Domains longer than 63 characters are invalid/broken

Added by Biological Component about 8 years ago. Updated over 7 years ago.

Status:Closed Start date:04/05/2011
Priority:High Due date:
Assignee:Max Goldberg % Done:

100%

Category:Back-end Spent time: 9.00 hours
Target version:YTMND 2.1 Estimated time:8.00 hours

Description

Attempting to open a url with a sub-domain 64 characters or longer will return "Server not found". (63 characters being the maximum between any two dots in a valid url, as far as I know)

The ytmnd creation page allows you enter a domain up to 128 characters in length. There's a plethora of broken sites if you browse for "least voted on"...just a bunch of sites floating around that nobody can view or vote on.

History

#1 Updated by Max Goldberg about 8 years ago

  • Status changed from New to In Progress

Confirmed, not sure how I missed this; I think this has been a bug since the beginning of YTMND.

Patched in revision r1871.

This is a note to add the following to the YTMND 2.1 upgrade script:

  • Truncate/rename or delete any sites with LENGTH > 63.
  • Truncate/rename or delete any site_creation entries with LENGTH > 63.

#2 Updated by Max Goldberg about 8 years ago

  • % Done changed from 0 to 20
  • Estimated time set to 8.00

#3 Updated by Max Goldberg almost 8 years ago

  • Status changed from In Progress to Closed

Just verified that in RFC 1035 "labels" (subdomains) must be no longer than 63 octets.

Created a migration script in the 2.1 manifest to fix and update domains > 63 characters long in Revision r2048 updated Site creator regex in Revision r2049.

This should be all fixed in 2.1.

#4 Updated by Max Goldberg almost 8 years ago

  • % Done changed from 20 to 100

#5 Updated by genako prowske over 7 years ago

Domain Name System or Domain Name Server terms and abbreviations glossary. DNS works as the yellow pages or phone books of the Internet. It tells your browser where the content for the requested URL is located to retrieve it.drug and alcohol rehab facility

Also available in: Atom PDF