Bug #14

Uploading instantly fails if you try to upload more than once without refreshing the page.

Added by super dreamkilla over 6 years ago. Updated over 5 years ago.

Status:Closed Start date:03/18/2011
Priority:Normal Due date:
Assignee:Max Goldberg % Done:

100%

Category:Back-end Spent time: 20.00 hours
Target version:YTMND 2.1 Estimated time:20.00 hours

Description

When creating a site, if your file fails to upload (due to timeout, file-size larger than 8mb, etc...) you get an appropriate alert message. But if you try to upload a valid file after that, you get the following alert message:

"The page at http://ytmnd.com says:
There were errors with your upload of "sound.wav":
No valid files uploaded. Error #2"

You have to refresh the page before the file will upload properly.

History

#1 Updated by Max Goldberg over 6 years ago

  • Status changed from New to Reproducable
  • Priority changed from Low to Normal
  • Target version set to YTMND 2.1

I just saw this today while fixing an upload bug. I am fairly certain it's due to the way the upload JavaScript juggles iframes, but I'm tagging this to make sure it gets fixed by 2.1 launch.

Thanks for the report.

#2 Updated by Max Goldberg over 6 years ago

  • Subject changed from Upload glitch to Uploading instantly fails if you try to upload more than once without refreshing the page.

#3 Updated by Max Goldberg about 6 years ago

  • % Done changed from 0 to 100
  • Estimated time changed from 1.00 to 20.00

All fixed in 2.1, all upload code was rewritten and made modular.

#4 Updated by Max Goldberg about 6 years ago

  • Status changed from Reproducable to Closed

#5 Updated by alicson katich over 5 years ago

Yes while uploading file one after other then it display an error message.For uploading another file i must have to refresh the page.Anyone have solution for this problem?Vispronet

#6 Updated by roger vincent over 5 years ago

Yes, even I got this report. It is important that this error should be removed and the bug should be fixed.
online business school

#7 Updated by Madelene Wunner over 5 years ago

Thanks a lot for your help. It was really required by me because I was wondering what to do when I got this error. So now I know that its not only who is facing such kind of error.
Regards,
Madelene- reverse cell phone lookup

#8 Updated by rudy shweitzer over 5 years ago

i got FAIL (120) error. And it says Please verify that you own the domain and that it belongs to a regular hosting account.
mosquito magnet

#9 Updated by barney ross over 5 years ago

Refreshing the page between uploads is very important as it can crash your uploads.
-Barney Ross
nice restaurants in harrisburg pa

#10 Updated by allen dorris over 5 years ago

This is a very serious problem. Everytime I have to refresh before uploading the next item. I hope this bug will be fixed very soon.
online bras

Also available in: Atom PDF